Trying to keep this short and sweet, I have some pressing questions that need answers:
- If a view is showing 2 different child components based on the URL through a router, should those components be in the components directory or views directory?
- When naming components, should names be capitalized like Participant.vue or participant.vue?
- Is it acceptable to use single word components like Participant.vue? If not, how should a component that displays information about a participant of a match be named?
- For components with multiple words, what naming convention should be followed? ParticipantMatches.vue, participantMatches.vue, participant-matches.vue, or Participant-Matches.vue?
- Would it make sense to prefix child component names with the parent component name for hierarchy purposes so that related components are grouped together in the IDE file tree?
For instance:
Participant.vue - Parent component
ParticipantMatches.vue - Child component of Participant.vue
ParticipantMatchesStats.vue - Child component of ParticipantMatches.vue
The only downside could be potential lengthening of component names.